ThinkPad W510 with unknown device PCI\VEN_8086&DEV_4239

Today’s challenge saw me build a ThinkPad W510 laptop with Win7 x64. All went well until I was left with one ? in device manager and it was the wireless adapter. System update didn’t find drivers for it so I was left to visit the wonderful new site and pull the driver manually. This is run of the mill usually and wasn’t bothered however after downloading and trying every wireless driver listed for a W510 I still had no joy.

Anyway I googled the device Instance ID of PCI\VEN_8086&DEV_4239 (from device manager) and found the type of wireless adapter in this machine is the Intel Centrino(R) Advanced-N 6200 AGN.
I went to Intel’s support website and looked for the drivers – and the latest version listed is currently 14.1.1.0 which i downloaded and installed. Still no driver loaded after running setup.

I then saw in the small print that you needed to use a previous release 13.5.0.6 for win7 x64.

http://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=19856
I downloaded this and it picked up my wireless adapter and installed fine!

I’ve achieved nothing today except this so thought it might help someone else.

But why doesn’t system update pick it up nor do they list this driver on their site when i narrow my selection to ThinkPad W510.. because they are clowns I tell you

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s